NHS claims resubmission issue

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 12:14 BST

Investigating

We are aware of an issue impacting NHS claim submissions and are actively working on a resolution
Posted Sep 07, 2026 - 11:08 BST
This incident affected: Claiming Services and NHS Integration.