Canada Only: Issues processing Manulife claims

Incident Report for Dentally

Resolved

This issue with Manulife has now been resolved.
Posted Apr 03, 2025 - 17:40 BST

Monitoring

We are aware of an issue with Manulife whereby claims are not processing due to "network error".

The root of the issue dot not exist in Dentally and the advice from Manulife is to "try again later".
Posted Apr 03, 2025 - 17:34 BST
This incident affected: Claiming Services.