Reports of slow perfomance

Incident Report for Dentally

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 08:59 BST

Monitoring

System performance should now be back to normal. Our teams will continue to monitor the results.
Posted Jun 10, 2025 - 08:40 BST

Investigating

We are currently investigating this issue.
Posted Jun 10, 2025 - 08:32 BST
This incident affected: Dentally Application.